Follow

Email clients supporting TLS 1.1+

Email clients supporting TLS 1.2

  • Outlook 2003
  • Outlook 2007
  • Outlook 2010
  • Outlook 2013
  • Outlook 2016
  • Outlook 2011 / MAC OSX 10.11 – 10.13
  • Apple Mail / OSX 10.12 (Sierra) and above
  • Mail / iOS 11+
  • Mail / Android 5+
  • Thunderbird 45.6+
Was this article helpful?
0 out of 0 found this helpful
Powered by Zendesk